Ticket #34 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Some questions have no answers

Reported by: sritter Owned by: tempjc
Priority: critical Milestone: Fall Weeks 1-3
Component: Race game Keywords:
Cc:

Description

Several of the datasets put 0 on the car and also have 0 on the left flag. I've seen this in DecToPct? on:

  • set 030
  • set 037
  • set 039

The second question in set 012 is also bad but in a different way. If I remember correctly, it counts the left lane as the correct answer, but the center lane is correct.

So, we need to fix these datasets and then QA all of them to make sure that there is a correct answer and that the correct answer is accepted.

Change History

comment:1 Changed 6 years ago by tempjc

  • Status changed from new to accepted

Those 4 sets (12, 30, 37, 39) have been fixed in test 1.

I also identified the primary cause for the faults in 30, 37, and 39. It appears that the selector value was supposed to be 0.0#, but the # was truncated, leaving the with problem with an incorrect 0.0 selector.

I am currently uncertain as to what caused the incorrect lane being marked as correct in 12. Because of this I will go through the sets by hand, until I can determine the root cause and find a more automated solution. After checking the sets I will open up a ticket for fixing the problems in the generator that caused this.

comment:2 Changed 6 years ago by tempjc

  • Status changed from accepted to closed
  • Resolution set to fixed

Additional fixes made in: Test 1 (15, 21, 36) and Test 3 (25, 29)

All of the bad questions appear to occur with target selector values less than 0.1.

In addition the the truncation problem above, likely problems with rounding/truncation place values of (e.g.) 0.3 as being larger than 4%.

Note: See TracTickets for help on using tickets.